SilkTest Question 45: How to fix no license for silktest_gui error?

My coworker Senior QA Engineer started to ask the question about no license for silktest_gui 8.0 error to filter candidates without practical experience. The question sounds as the following: In preparation for major production release of your application you tried to start Silk Test 8.0 automation tool and suddenly getting the following windows pop up with error.

SilkTest license
Everything was working perfect in the quality assurance lab yesterday. Give at least two ideas how to fix it?

The most plausible reason would be that SilkTest license was not installed at all or in case it was installed you pointed your Silk Test to the wrong server address or wrong port number.

One more explanation is that everyone else in your QA team use floating licenses and your coworkers exhaust all SilkMeter's resources. You need to open the SilkMeter User Policy Administrator and verify that your licenses are still there and not checked out by anyone else.

By the way the error for SilkTest 2006 would be no 'license for silktest_gui 8.1' and you would not find anything about this error in SilkTest documentation.


Anonymous said...

Is there any way I can work on SilkTest without using the license for few days?

Anonymous said...

try demo version

Anonymous said...

You can also use 3rd point. Sometimes license config (smadmin.exe) will throw error like 'CosPropertyService failed to communicate with server'. The license server and port will be available.

To this scenario, you restart the machine ones and try again.

- Palani.

Anonymous said...

I have uninstalled SilkTest and claer all the relative files, then the SilkTest works well.
Hope this can provide some help.
BTW, I use the evaluation version that only have the 30 days.

SilkTest interview questions for QA Testers